Re: External changes
Steve Huss-Lederman (email@example.com)
Mon, 14 Apr 1997 14:47:13 -0500 (CDT)
> I don't like the proposed name changes for the GR functions:
> MPI_REQUEST_MARK_COMPLETE can only be called for a GR, not any other
> request object, so the name is misleading; I prefer
> MPI_GR_MARK_COMPLETE or even MPI_GR_COMPLETE.
> MPI_REQUEST_START_GR is also misleading and longer to type than
> I guess the issue would be moot if there was a GR object distinct from a
> request object, but unfortunately that is not the case :-)
Yes, request is there since GR is a type of request. I have to agree
that the asymmetry seems confusing. If we use new names, how about
changing MPI_REQUEST_MARK_COMPLETE to MPI_REQUEST_MARK_COMPLETE_GR. I
am open to other reworkings of the name to fix this up.