MPI_REQUEST_MARK_COMPLETE can only be called for a GR, not any other
request object, so the name is misleading; I prefer
MPI_GR_MARK_COMPLETE or even MPI_GR_COMPLETE.
MPI_REQUEST_START_GR is also misleading and longer to type than
I guess the issue would be moot if there was a GR object distinct from a
request object, but unfortunately that is not the case :-)