Re: GR proposal
Raja Daoud (email@example.com)
Thu, 16 Jan 1997 16:49:01 CST
>> An alternative that I suggest is to let GRs be nonpersistent, and let
>> MPI_Request_init take all the callback functions as well as extra
>> state, and actually start the nonpersistent GR. The it would
>> require just one function call:
>This is an excellent point. Can't say that I find anything wrong with it. Raja?
I find this to be a nicer solution, and if it pleases the key client for
generalized requests, so much the better. We just need to come up with
a better name for MPI_Request_init() to remove the similarity to the
MPI_*_init() calls. For example: MPI_Irequest()? ;-)
Raja Daoud Hewlett-Packard Co.
firstname.lastname@example.org Convex Division